To run this application you must first install .net framework v4.0

when you face the issue “to run this application you must first install .net framework v4.0″,  check the following things

1) The System may not be having the .Net framework 4.0

2) It may be having the .Net framw work , bur may not be installed properly.

3) It may not be having the full version of the .Net framwwork 4.0

How can we Resolve this issue.

1) As i seen many article thy told to Replace the below piece of code in the App.config file in the project you are created and run the setup file, it may work[I am not tried this one]

<startup>
<supportedRuntime version=”v4.0″ sku=”.NETFramework,Version=v4.0″ />
</startup>

Replace with the

<startup>
<supportedRuntime version=”v4.0″ />
</startup>

Note :- When .Net framework version is changed [Right click on project and Go to properties and in that Target framework ], the above piece of code will change.

 

2) Install the .Net framework 4.0 full version.[If any existing .Net framework 4.0 exist (Like Microsoft .Net 4.0 client and Microsoft .Net 4.0 Extended) uninstall it] and then run the set up file. it will work fine. I tried this one from my side.

For downloading .Net framework version 4.0, refer the below path.

Please let us know for any improvement or suggestions. Many thanks!!!!

Read previous post:
sharepoint interview questions – part 8

I will provide the elaborate answer to the below question in the next post and also I will talk about the some...

Close